Name convention

Description

1. As a developer, I suggest that Entity.nameMatches () is renamed to nameEquals () because no matching is involved.

2. In addition, the class "relationship" should be renamed to "Relationship Type", to be clearly distinguished from the class "relation".

3 .Furthermore, the relationship types "Parent -> Child" and "Child -> Parent" should be clearly distinguished and not both subsumed under FATHER_CHILD.

4. The "Join" class should be renamed to "JoinType" or "JoinOperator", as well as the class "Operation" to "ComparisonOperator" and the class "Operator" to "BooleanOperator".

5. Furthermore, Operator.OPEN and Operator.CLOSE should be removed because parentheses are only required for linear syntax and not for a syntax tree.

Activity

Show:
Angelika Wittek
August 31, 2017, 10:54 AM

Assignee

Angelika Wittek

Reporter

Hans-Jörg Kremer

Labels

Process Step

Global

Eclipse Project

MDM Business Layer

Status

New

Components

None

User Story Name

Name convention

Implementer (Company)

None

Customer (Company)

None

Epic Link

Fix versions

Affects versions

Priority

Major
Configure